GlockTalk.com
Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.
Reply
 
Thread Tools Display Modes
Old 04-28-2011, 06:36   #1
vafish
Senior Member
 
vafish's Avatar
 
Join Date: Mar 2003
Location: Commonwealth of Virginia
Posts: 23,742
Lone Wolf 3.5 connector and NY1

I've been running a LWD 3.5 connector for a while, I liked the lighter pull, but thought it felt kind of mushy. I was ordering some parts for a well used g23 I just picked up and figured I'd give the 3.5 and ny1 combo a try.


My parts arrived yesterday so after dinner I had glocks all over the kitchen table.


First up was my 2nd gen g17. It was pretty dirty must have been a long time since its last detail strip nut the upgrade seems to have gone fine. Got all the parts in place and function check seems ok. Field stripped it back down and lube it up.


Next up was my 3rd gen g19. Upgrade seemed to go fine, function check ok, go to remove slide and lube it up and the slide won't come off. Only goes about 1/2" forward. So I pop the cover plate off, remove the slide, check it out, looks fine, put it back together. Same thing.


Did that a couple more times and my son notices that the part that releases the strikers is sitting up higher on the 19 then the 17.


The trigger is not staying all the way to the rear when dry firing. I can field strip it as long as I hold the trigger all the way to the rear. That's a pita to pull down on the slide lock and pull the trigger at the same time.


Did I do something wrong on the g19 or is that normal with the extra strength of the ny1?


__________________
__________________
"If your plan is for one year, plant rice.
If your plan is for ten years, plant trees.
If your plan is for one hundred years,
educate children." -- Confucius
vafish is offline   Reply With Quote
Old 04-28-2011, 17:29   #2
JR
GT Sponsor
 
Join Date: Dec 1998
Location: Oldtown Idaho USA
Posts: 3,936
Send a message via AIM to JR Send a message via Yahoo to JR
No problem, this happens with some pistols. At least you figured out how to get the slide off!
__________________
www.lonewolfdist.com
JR is offline   Reply With Quote
Old 04-28-2011, 19:29   #3
vafish
Senior Member
 
vafish's Avatar
 
Join Date: Mar 2003
Location: Commonwealth of Virginia
Posts: 23,742
Quote:
Originally Posted by JR View Post
No problem, this happens with some pistols. At least you figured out how to get the slide off!
8 years on Glock Talk I had to pick something up that was useful.

And tell Anna the strange part was a mag catch spring.
__________________
"If your plan is for one year, plant rice.
If your plan is for ten years, plant trees.
If your plan is for one hundred years,
educate children." -- Confucius
vafish is offline   Reply With Quote
Old 05-01-2011, 20:26   #4
vafish
Senior Member
 
vafish's Avatar
 
Join Date: Mar 2003
Location: Commonwealth of Virginia
Posts: 23,742
JR,

Is it also common to have a couple of mis feeds right after changing trigger parts?

I took the two guns to the range today. 17 was flawless. 19 I started out with a single round, it went bang, loaded 2 rounds first went bang, second Hung up on the feed ramp. Loaded 3 rounds and same thing, but round 3 chambered fine. Then I put 50 rounds through it with no problem.

Switched over to the AA conversion kit. Had a couple of failure to extract, but the kit was dirtier then a jersey girl. Gave it a quick clean and it was flawless as well.
__________________
"If your plan is for one year, plant rice.
If your plan is for ten years, plant trees.
If your plan is for one hundred years,
educate children." -- Confucius

Last edited by vafish; 05-01-2011 at 20:31..
vafish is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 22:48.



Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 1,120
311 Members
809 Guests

Most users ever online: 2,244
Nov 11, 2013 at 11:42