Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
Reply
 
Thread Tools Display Modes
Old 10-08-2012, 17:19   #1
Pier23
Senior Member
 
Pier23's Avatar
 
Join Date: Feb 2012
Posts: 2,144
P220 not chambering with full mag

Gentlefolk,

Back from playing with my P220 with a Sig mag. After I cleaned the weapon, I fully loaded the mag with 7 rounds FMJ, released the slide, and found the round did not chamber.

Works fine with six rounds in the mag, but that 7th round really, really binds the cartridges. i needed to push the 7th cartridge out with a tool to get it out of the mag.

Odd, because everything was fine at the range....

Ideas? I figger I need ro tear down the mag and see if something got bent, but I am not that hard on mags....????
Pier23 is offline   Reply With Quote
Old 10-09-2012, 04:35   #2
silversport
Senior Member
 
silversport's Avatar
 
Join Date: May 2003
Location: Chicagoland USA
Posts: 2,803


I have always found the 7 rounders to be tight when fully loaded and downloading by hand can be a finger buster...downloading by using the pistol has never been an issue for mine...currently I use my older P220 with the newer P220 8 round (MecGar made) magazines...I have read that similar 8 rounders from ACT Mag work as well...

It couldn't hurt to disassemble the magazine to see if it is binding and assembled properly...good luck and hope you get it settled soon...

Bill
__________________
****G17**G21 Gen4**G30S****
*NRA BENEFACTOR MEMBER/LEAA LIFE MEMBER*
*Like What You've Got?...Thank a Vet!*
silversport is offline   Reply With Quote
Old 10-09-2012, 07:40   #3
Gary1911A1
Senior Member
 
Gary1911A1's Avatar
 
Join Date: Jun 2005
Location: Ohio for now
Posts: 3,617
Have you tried leaving the magazine loaded for a week or so? Sometimes that helps with the initial set most springs seem to have when new.
Gary1911A1 is offline   Reply With Quote
Old 10-13-2012, 08:19   #4
Pier23
Senior Member
 
Pier23's Avatar
 
Join Date: Feb 2012
Posts: 2,144
Quote:
Originally Posted by Gary1911A1 View Post
Have you tried leaving the magazine loaded for a week or so? Sometimes that helps with the initial set most springs seem to have when new.
Yeah..lthis isnt a new piece, and at the range I was fully loading the mag and it was chambering fine.

Not a big deal since I don't fully load my mags anyway, more of a quirk that suddenly appeared.

Mag seems to be seating correctly.

Will play with different mags and see if I can find a common thread.
Pier23 is offline   Reply With Quote

 
  
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 18:27.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 1,289
389 Members
900 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31