GlockTalk.com
Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-11-2013, 17:29   #1
Z71bill
Senior Member
 
Z71bill's Avatar
 
Join Date: Feb 2007
Location: Texas
Posts: 10,842
Serpentine Belt Noise / Chirp?

2007 Tahoe 5.3L V8 - ~~ 25K miles

I only drive it a few times a month - mostly used for vacation trips --

I started it up the other day using the remote start - it was COLD and raining - and heard a slight chirp - sounded like a squeaky belt.

I say "slight" because if I am in the drivers seat I can not hear it -- after the engine runs for a while / drive a few miles it is quiet - no chirp even when I standing in front of the truck with the hood open.

I started the engine a few times now - hear the chirp - if I put a single drop of water on the serpentine belt (inside groves) the noise disappears instantly -

Should I replace the belt? It looks like new - no wear - no cracks.

Use "belt dressing" (I hate this ****)

Don't worry about it because it is normal?
Z71bill is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 23:05.



Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 1,028
268 Members
760 Guests

Most users ever online: 2,244
Nov 11, 2013 at 11:42