Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
Reply
 
Thread Tools Display Modes
Old 11-06-2012, 17:47   #1
me_etc
Registered User
 
Join Date: Oct 2012
Posts: 7
Glock 19 Gen 3 ejection issue solved...

I own a recently born Gen 3 (TTL*** 8/2012). I quickly noticed the erratic ejection with target ammo. In particular, Federal 115 gr fmj would eject BTF or top of head 10-20%. It has never had a FTE and no stove pipes in 1000+ rds. So in reading all the discussion and debate about potential solutions, I examined the pieces/parts that have been in question. My extractor is a non-dip MIM, so I decided since this type seems to have less reported issues, I would start by replacing the ejector. It was the 336. I ordered a Gen 4 trigger block from Lone Wolf which they stated had the 30274 ejector and traded out the ejector. (The Gen 4 trigger block is not compatible with the Gen 3) This was a total of $12 for part with shipping. I am happy to report that I shot 100 rds with it today using the same ammo as before and had the most consistent and proper ejection of shells to date with no BTF. Obviously, plenty more rounds will be necessary to deem it as completely cured, but a good start!

I realize that many people have had limited success with replacing/trying different things, but this was a fairly inexpensive one that may be worthy of being the first thing to try.

Good luck to all Glock owners in their pursuit of Glock Perfection!
me_etc is offline   Reply With Quote
Old 11-06-2012, 17:51   #2
SJ 40
Senior Member
 
SJ 40's Avatar
 
Join Date: Jan 2011
Location: Vermont
Posts: 7,759
Your fix has worked for some and then not for others, their seems no one fix for all guns. Although I suspect a in spec properly made extractor would be a big leap in the right direction. SJ 40
SJ 40 is offline   Reply With Quote
Old 11-06-2012, 17:55   #3
Bruce M
Senior Member
 
Bruce M's Avatar
 
Join Date: Jan 2010
Location: S FL
Posts: 23,625
Good to hear your issue seems to have been resolved.
__________________
Bruce
I never talked to anyone who had to fire their gun who said "I wished I had the smaller gun and fewer rounds with me" Just because you find a hundred people who agree with you on the internet does not mean you're right.
Bruce M is offline   Reply With Quote
Old 11-06-2012, 19:47   #4
me_etc
Registered User
 
Join Date: Oct 2012
Posts: 7
I hear you SJ, but I figure if those of us who have issues and resolve them report what they did, we'll get a better idea of what's working and/or where to start.
me_etc is offline   Reply With Quote
Old 11-06-2012, 20:15   #5
SJ 40
Senior Member
 
SJ 40's Avatar
 
Join Date: Jan 2011
Location: Vermont
Posts: 7,759
Quote:
Originally Posted by me_etc View Post
I hear you SJ, but I figure if those of us who have issues and resolve them report what they did, we'll get a better idea of what's working and/or where to start.
You bet didn't mean to rain on your parade,I'm glad you were able to get it up and shooting.
Now it would be great if Glock would devote some Serious thought to the problem and solve it for every one.
SJ 40
SJ 40 is offline   Reply With Quote
Old 11-06-2012, 20:41   #6
Buckshot Barry
Senior Member
 
Join Date: Jul 2004
Posts: 600
We both have a 19 in the same serial number range. Mine suffered from BTF too, but I also have a 2005 G17 that I was willing to swap slide components with.

Would you please look at the extractor pictures in this link and what I did to cure my BTF issues and comment on how your extractor looks.

http://www.glocktalk.com/forums/show....php?t=1450148

Thanks

Last edited by Buckshot Barry; 11-06-2012 at 20:43..
Buckshot Barry is offline   Reply With Quote
Old 11-06-2012, 21:31   #7
Glock40man
Senior Member
 
Glock40man's Avatar
 
Join Date: Feb 2011
Posts: 6,396
__________________
_____
.... you put a whole new shine on the word overkill. "When you need it, and don't have it.... you sing a different tune."- M. Gross
Glock40man is offline   Reply With Quote
Old 11-06-2012, 22:20   #8
me_etc
Registered User
 
Join Date: Oct 2012
Posts: 7
Buckshot Barry: My extractor is also a non dip MIM like yours. I too had gouges, but not quite as deep as yours. There is 2 much smaller ones in that same corner. It looks like it could definitely be a production tolerance issue. Mine has more of the black finish wearing through, though, possibly from the extra rounds through it in comparison. I'm glad to hear you got yours working!
me_etc is offline   Reply With Quote

 
  
Reply


Tags
30274, 336, btf, ejection, ejector
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 09:59.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 968
257 Members
711 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31