Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 07-16-2012, 18:36   #1
Gellorock
Member
 
Join Date: May 2012
Posts: 40
Bought a new(used) Springfield EMP ... Couple of concerns.

Hey guys,

I just bought an EMP in 9mm. The guy I bought it from said he put maybe 400 rounds through it. I called Springfield with the serial # and they told me its production date was January 2012.

Anyway, I took it to the range today and shot 200 rounds through it. I love the gun, everything went well but I had two issues:

1- the slide failed to lock back twice on the empty mag. After shooting the last round. It happened with 2 different factory mags.

2- I had 2 failures to fire. I re-cocked the hammer and the round fired on the second try. This happened twice with Winchester white box ammo.

Do you think these issues will go away with more shooting or is there anything I need to tweak to fix them.

Appreciate the help!
Gellorock is offline   Reply With Quote

 
  
 


Tags
9mm, emp, short action 1911, springfield
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 02:58.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 566
123 Members
443 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31