View Single Post
Old 02-06-2013, 10:17   #17
ctious
Senior Member
 
Join Date: Dec 2011
Posts: 535
Quote:
Originally Posted by dm1906 View Post
That's a modest load of Longshot, and LS is a fairly slow powder. It's only a little slower than BD, maybe just enough.

Are you using a Mag primer? I use them for most BD and slower powder loads (NOT 800X), and they are LS friendly. Maybe try them and work up a load. It may help to get the powder lit off a bit more uniformly.

Tac 1 is a good lube, but it's fairly low temp. I don't use it because on a warm summer day, even in the shade, it will flow from cartridges and make a mess in the trays and chambers (and mags, and fingers, and.....). Very good for really cold climates, and should have been ideal for your use under those conditions. Maybe cut in some hi-temp paraffin to firm it up a bit? Just enough, before it gets smoky (start at 10%). Generally, lubes that don't require heat to flow (room temp), don't need much heat to flow when it shouldn't, either. If that's what got into the works, I can see it locking up the slide inerds and trigger assy in sub-freezing temps (don't forget to give the trigger assy a good cleaning, too).

Like I said, it really looks like you set yourself up for a perfect storm.

No standard 300s. I will have to try mags. Yeah the lube is the tac 1 soft. Being its hardly above 20 deg here all winter. I have reg tac 1 also.
Will have to see how that works also. The days this happened is was neg and singles. Cold. Burrr. Why do I live here. Lol.

Last edited by ctious; 02-06-2013 at 10:28..
ctious is offline   Reply With Quote