View Single Post
Old 03-14-2011, 11:05   #1404
LWD Armorer
GT Sponsor
 
LWD Armorer's Avatar
 
Join Date: Oct 2006
Location: Oldtown
Posts: 367
Al Swearengen,
The two pins above the trigger guard. One, trigger pin (larger of the two, closest to the trigger guard); this pin should not be working its way out. The slide stop lever is locked in with the trigger pin. Make sure it is installed correctly. Two, locking block pin (smaller of the two, positioned highest above the trigger); is this a used pin? You are the first to say the pin is moving. All (if they say anything) state the pins are tight.

Might be best to give me a call so we can work this out over the phone, if you like.



Pardoner,
If you look at the first start of the video it states; “TimberWolf Frame, New Lone Wolf G34 Top End too!” He is using Lone Wolf frame, slide, barrel, and any other parts we make.


rkrk,
The issue was with the “PROTO” frames. With the production frames all these issues were resolved. The only thing I can think of is maybe they received the old back straps and mag catch. This can no longer happen due to all older parts have been tossed in the garbage.
__________________
Dan
Armorer / Engraver

To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

Want to see more?
Visit
To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

Last edited by LWD Armorer; 03-14-2011 at 11:22.. Reason: up date to Mr. rkrk
LWD Armorer is offline   Reply With Quote