Glock Talk

Glock Talk (http://glocktalk.com/forums/index.php)
-   1911 Forums (http://glocktalk.com/forums/forumdisplay.php?f=77)
-   -   Bought a new(used) Springfield EMP ... Couple of concerns. (http://glocktalk.com/forums/showthread.php?t=1432684)

Gellorock 07-16-2012 18:36

Bought a new(used) Springfield EMP ... Couple of concerns.
 
Hey guys,

I just bought an EMP in 9mm. The guy I bought it from said he put maybe 400 rounds through it. I called Springfield with the serial # and they told me its production date was January 2012.

Anyway, I took it to the range today and shot 200 rounds through it. I love the gun, everything went well but I had two issues:

1- the slide failed to lock back twice on the empty mag. After shooting the last round. It happened with 2 different factory mags.

2- I had 2 failures to fire. I re-cocked the hammer and the round fired on the second try. This happened twice with Winchester white box ammo.

Do you think these issues will go away with more shooting or is there anything I need to tweak to fix them.

Appreciate the help!

JTBTACTICAL 07-16-2012 20:54

Quote:

Originally Posted by Gellorock (Post 19203075)
Hey guys,

I just bought an EMP in 9mm. The guy I bought it from said he put maybe 400 rounds through it. I called Springfield with the serial # and they told me its production date was January 2012.

Anyway, I took it to the range today and shot 200 rounds through it. I love the gun, everything went well but I had two issues:

1- the slide failed to lock back twice on the empty mag. After shooting the last round. It happened with 2 different factory mags.

2- I had 2 failures to fire. I re-cocked the hammer and the round fired on the second try. This happened twice with Winchester white box ammo.

Do you think these issues will go away with more shooting or is there anything I need to tweak to fix them.

Appreciate the help!

Congrats on the new gun! Those springfields sure are nice!

1.) Is there any chance that your thumb was resting on the slide stop lever?

2.) I would guess that this issue has to do with the ammo, not the gun. Could have been hard primers. WWB is good range ammo, but it isn't known for it's superior quality. It's good for the price.

Go out and shoot it again!

glock2740 07-16-2012 21:52

Congrats! I recently picked up a EMP in 9mm and LOVE it! Great CC 1911. :thumbsup:

http://i914.photobucket.com/albums/a...911/EMP2-1.jpg

http://i914.photobucket.com/albums/a...911/EMP1-1.jpg

Quack 07-17-2012 06:31

check for crap in the FP channel

slide lock issue is probably your support hand thumb resting on the slide stop.

dakrat 07-17-2012 13:38

the first thing you should do when taking home a firearm especially used one is to detail strip it for possible worn/damaged parts. clean it thoroughly, lube it and shoot it. try different ammo. the issues you mentioned are minor and can be fixed easily. the worst case fix would be a new magazine and mainspring. but try the ones mentioned earlier first.

Alcoy 07-17-2012 13:44

if the suggestions above do not fix your gun issue, Springfield has great customer service. I sent a gun i bought used, they fixed it and paid for fedex both ways.

congrats on your emp.

Gellorock 07-17-2012 17:32

Thanks for the input guys.

I detail stripped the gun and made sure everything was nice and clean (including the fp channel). I have a sa micro compact and have never had my grip bump the slide lock, but since the emp is a bit thinner maybe I was doing it and not realizing. Ill keep an eye on that when I go back to the range. I'm going to also see if it happens with one mag specifically, but hopefully it's just operator error!

bac1023 07-17-2012 19:56

Congrats on the EMP! :cool:

Happy Hunting 07-17-2012 20:07

I envy EMP owners and will one day own one. I haven't seen one for sale at my price target yet. They must sell pretty well used.

Gellorock 07-17-2012 22:01

I picked this one up for 750 off an ad i saw posted on flguntrader.com. I feel like it was a steal given condition and production date :supergrin:

Wolf Spyder 07-18-2012 00:47

Both my Brother and his wife carry the Springfield EMP. Personally, I don't like them. Both pistols have had similar problems to what you are having with yours. Also they are having trouble with the magazine where the follower tips causing a round to nose dive and that in turn causes a Failure to Feed.

We have had the two pistols for several months and have fired close to 800 or 1000 rounds from each. They seem to be getting better, and are almost 99%, but I am a Glock guy. I have never had a malfunction from either of my 10mm Glock 20's. So for me the EMP is a "No-Go" because of these magazine related issues.

If it is not 100% then I won't carry it.






Gary1911A1 07-18-2012 07:49

Quote:

Originally Posted by Gellorock (Post 19207803)
I picked this one up for 750 off an ad i saw posted on flguntrader.com. I feel like it was a steal given condition and production date :supergrin:

For that price and only 400 rounds fired you did well. The slide not locking back on two magazines could indicate a problem with the slide stop, but it could be the ammo too as Winchester White Box is on the mild side. I'd shoot it some more and wouldn't be surprised if the problem disappears.

Troubled Gecko 07-18-2012 17:14

Replace the firing pin spring, if it's weak you'll get failure to fire. www.gunsprings.com Wolff makes very good replacement springs. I would also check the firing pin and firing pin channel for rust/debris.

jg420 07-18-2012 19:24

Congrats those are really nice Springfields, I have fondled a couple at my local shop.

BerettaGrl 07-18-2012 19:35

I had problems with my EMP not going to slide lock. It had something to do with my grip... Fixed the grip, fixed the problem. If I have a noob shooter that I'm teaching, the problem can re-occur. Other wise, it's been pretty flawless. It's soooo pretty too.


All times are GMT -6. The time now is 08:41.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2013, Glock Talk, All Rights Reserved.