GlockTalk.com
Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Rate this Entry

follow up on TSG-22 kit

Posted 02-08-2011 at 16:38 by bigghoss

hey guys I went back out to the range and shot some more. I have more video but the jist of it is, CCI feeds fine but is harder to set off. the automatch doesn't feed as well from the top of the mag but that seems to be more related to spring pressure in the mag than the ammo. I did not see any light-stike issues with the other ammo except peters. most others just sucked. the kit ran so much better when I got up around 500-600 rounds through it. all issues has reduced dramatically but still exist. I'm going to load the mag to capacity and let it sit for a week and see if that helps with the spring issue and I'll have to cal tac-sol and get them to send me the updated spring cups. I was out at the range for maybe 3 hours and recorded a lot of footage so it'll take a while to get it uploaded. I'm busy this whole week so it might not happen until sunday or monday and it will probably be in 3-4 parts.

I'm very confident I'll get the issues worked out and have a kit that runs almost as good as the normal glock does.
Posted in Uncategorized
Views 4448 Comments 4 Edit Tags Email Blog Entry
« Prev     Main     Next »
Total Comments 4

Comments

  1. Old Comment
    Dave.1's Avatar
    Bigghoss, sorry to read in GG that you had to send your TS kit back. I'm sure they'll get it right.

    Appreciated all your work and information.

    Dave
    Posted 03-17-2011 at 10:54 by Dave.1 Dave.1 is offline
  2. Old Comment
    bigghoss's Avatar
    just received a tracking number and it looks like I'll be getting the kit back on monday so hopefully by saturday I'll have a followup on how it's working.
    Posted 03-17-2011 at 21:45 by bigghoss bigghoss is offline
  3. Old Comment
    keenshooter's Avatar
    Just ordered mine from cabels
    Posted 05-21-2011 at 07:26 by keenshooter keenshooter is offline
  4. Old Comment
    bigghoss's Avatar
    well I hope it works out. they seem very eager to make it right but mine came back and it's still having some issues.
    Posted 05-21-2011 at 12:02 by bigghoss bigghoss is offline
 

All times are GMT -6. The time now is 02:11.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 641
150 Members
491 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31